Versions incompliance

I do have some issues with versions incompliance: 

  • omegaml 0.13.0 requires scikit-learn<0.22,>=0.20
  • ctgan 0.2.1 requires scikit-learn<0.23,>=0.21

When using scikit-learn==0.21.0 and higher (which should be ok for both omegaml and ctgan) the backend container can not be started. I got such traceback:

ModuleNotFoundError: No module named 'sklearn.utils._testing'

When using scikit-learn==0.22.2 - backend works, but shows an warning:

omegaml 0.13.0 requires scikit-learn<0.22,>=0.20, but you'll have scikit-learn 0.22.2 which is incompatible.

As for now, I am using scikit-learn==0.22.2.

But what should be the best option?


Sign In or Register to comment.